Top.Mail.Ru
? ?
joyce
*scratches head* 
3rd-May-2001 11:51 am
[root@noc-linux joyce]# rpm -i licq-1.0.3-1.i386.rpm
only packages with major numbers <= 3 are supported by this version of RPM
error: licq-1.0.3-1.i386.rpm cannot be installed
Comments 
3rd-May-2001 12:07 pm (UTC)
The RPM was created by RPM 4.x, and you're using RPM 3.x.
3rd-May-2001 12:10 pm (UTC)
ok, i'll upgrade rpm.

that error message still doesn't make sense, though.
thanks, hon. =]
3rd-May-2001 12:29 pm (UTC)
All rpms get tagged with a major version number. The major version number of the rpm you were trying to install wasn't 3 or less (which is all your copy of RPM understands), so rpm bailed out with an error message saying that it's an unsupported rpm.
3rd-May-2001 02:01 pm (UTC)
how is 1.0.3-1 not less than 3? =]
3rd-May-2001 05:25 pm (UTC)
Exactly. If you know what major numbers are, I guess it makes sense, but there's nothing in the error message that gives you any clue that it's rpm's problem, not the package you're trying to install.
This page was loaded Feb 24th 2024, 3:08 pm GMT.